Power Outage at F.L Stanton

Incident Report for Atlanta Public Schools

Resolved

This incident has been resolved.
Posted May 01, 2025 - 14:20 EDT

Identified

A power outage has been identified at F.L Stanton Elementary School. The estimated restoration time for this outage is 3:00pm.
Posted May 01, 2025 - 13:22 EDT
This incident affected: APS Locations (FL Stanton Elementary School).